
Program Overview

The Schedule Card Creator is an application that allows the user to create, save, and export
a weekly schedule image that can be posted outside an office door or dropped into a web
page or a CMS such as Canvas. This program was really written for me to experiment with
some PyQt functionality that is to be incorporated in a different project, but since it might be
of interest to others I finished it into a schedule creation application. The program interface
has three main areas.

Layout Option window on the left.
Schedule Item listing in the lower right.
Schedule Card Image in the upper right.

Both the options window and the schedule item listing are resizable and collapsible. Just
drag the division between the windows to resize and drag to the edge of the application to
collapse. The program offers several options for altering the schedule card layout and has
10 user-defined styles for rendering each schedule item. In addition there are facilities for
saving and loading both the complete schedule and just the layout option information,
copying and saving the schedule image, and printing the schedule image.



Constructing and Editing a Schedule

The schedule card is populated by adding schedule items to the list. Select Edit > Add New
Schedule Item to create a new schedule item for the card. You can also use the toolbar
button for this or Ctrl+A. When this is selected the following dialog box will appear for you to
input a new item.

The style category is a simple drop-down selection of 1-10. This designates the style
options that are used for the item.

The item text is free form text that will be displayed in the schedule. You may use as
many lines as you would like. Note that text is not wrapped inside the schedule item. The
fonts are resized so that the given text fits the available space. Hence you do not want the
lines to be too long nor do you want a lot of lines for a time slot that is not very long.

The days of the week are check boxes for the days this event is happening. The
schedule card will display Monday to Friday unless an event is scheduled for Saturday or



Sunday and then these days will be added to the schedule card.
The start and end times are when the event starts and ends. These are to be input

using a 24 hour clock. The display will be using a 12 hour clock.

Once the data is entered and OK has been selected, the new item will be added to the
schedule. It will appear in the schedule item list at the bottom and appear in the schedule
image. Note that in the schedule list all schedule items are on a single line and the line
breaks are given by //. Also, a schedule item that is not within the starting or ending times
will either be partially displayed or not displayed at all. The starting or ending times are not
altered by the schedule item times.

To edit an item that is already entered you can double-click (or Ctrl+Click) the event in the
schedule image. You will note that when you hover over the event it becomes "highlighted"
with a cross-hatch pattern. You can also double-click the item in the listing at the bottom,
hitting the enter key or selecting to edit from the menu or toolbar, with the item selected will
also open the editor dialog. The editor dialog is the same as for adding a new item.



In addition to adding and editing items you can clone an item by selecting Edit > Clone
Schedule Item from the menu or clicking the clone tool in the toolbar. This will create a copy
of the selected item and then you can edit one of the clones with other settings. You can
delete a schedule item by selecting it in the schedule item list and either hitting the delete
key or selecting Edit > Delete Schedule Item from the menu. You can also remove the entire
schedule by selecting Edit > Delete Schedule from the main menu.

Items that overlap in times will show up as red in the schedule item list. These should be
edited so that there is no time overlap, or else the image of the schedule may be
unpredictable. The program also offers standard undo and redo options to undo unwanted
edits. The undo and redo history stores only the schedule items and not the options, these
are kept separate by design.

The other input is for the header area. On the left in the options window there is a Header
section. Two turn the header on and off simply double click the Include item under Header.
You can put in a left, center, and right single line of text. As with the schedule items you will
want to keep these short. To add in text to any of these sections double-click the Left Text,
Center Text, or Right Text options below the Header title. A small dialog box will appear for
you to add or edit the text in those sections. We will discuss the other layout options in a
separate section of this help system. Once you are finished entering the items (and
adjusting the options to your liking) your screen will look like the following. At this point you
are ready to save and/or print the card.



Layout Options

The window at the left displays the layout options for the program. At the top are some
general layout options and below those are the options for each of the ten styles for the
schedule items. To change any of the options simply double-click on the option. In some
cases, like fonts and colors, a dialog box will appear allowing you to input your preferences.
In other cases the program will either toggle the selection on and off or cycle through the
options.

General
Time Range: This sets the starting and ending times of the schedule card. These are not

altered by the times of the schedule items and schedule items that are outside this range may be
clipped or not show at all.

Background Color: This is the color of the background in the schedule item area. This color
is not used in the days and times area or the header area.

Outline Color: This is the color used for the outline of the card as well as the outline for each
schedule item and the divisions between the days and times.

Font Auto-Resize: This is the mode used for automatically resizing the fonts. There are three
modes: Global, Fixed, and Off. In Global mode the program will automatically select the font size
of all the fonts on the schedule to best fit their available space without overlapping into the other
schedule items. This is the default mode of the program and really what it was designed to do.
The automatic font resizer will start at the minimum font size from the options and increase the
font size until the largest font possible still fits in all available spaces. When in Fixed mode the
font size that is used is the minimum font size from the options. When the resizing is turned off
the program will use the font sizes from each of the font options selected by the user. Note that
when printing the Global mode is used no matter what this option is set to. Due to the differences
in font metrics of graphical fonts between screen and printer devices the Global setting will
produce the most consistent results when printing.

Note that even if an item is off the schedule image, it was given times that were outside the time
range, it will still be used in the calculations of the font size when in global resizing mode.

Minimum Font Size: This is the smallest the font size will go in Global mode ad is exactly the
font size used in Fixed mode. If the text is too large for its available space at this size it will enter
other schedule items and either overwrite or be clipped. It is good to keep this value set low but
not too low.

Resize Adjustment: This is the point size decrease imposed on the global font size selection.
Since the program, in Global mode, will set the font size to the largest possible font it may appear
too large for some users. Setting this option will decrease the font size by the given number of
points, with a minimum set to the given minimum. This option can stay at 0 (no adjustment, use
optimal size) but if you wish to fine-tune the font size you can use this.

Days & Times
Background Color: This is the color of the background in the days and times area.
Text Color: This is the color used for the text of the days and times.



Font: This is the font used for the days and times. Depending on the resize mode being used
the font size may be altered.

Hour Divisions The hour divisions are horizontal lines at each hour that go across
the schedule item area. This may make it easier for the reader to see when each item
starts and ends.

Include: Turn the divisions on and off.
Color: The color used for the divisions.

Printing
Dimensions: This is the width and height in inches of the printed schedule card.
Offset: This is the horizontal and vertical offset in inches of the upper left corner of the

printed schedule card. Since most printers have a printing area less than the are of the page you
will want this between 0.5 and 1 inch so that the printer does not clip the image.

Scaling: There are three scaling modes that can be used: None, Height to Width, and Width
to Height. In None mode the printed image has the given dimensions. Since these dimensions
may not match the aspect ratio of the image being viewed on the screen the printed image may
look a little different. In Height to Width mode the program will set the height of the printed image
to match the width and the current aspect ratio of the viewed image. In Width to Height mode the
program will set the width of the printed image to match the height and the current aspect ratio of
the viewed image. Note that these scaling options could easily set either the width or height to a
value that is outside the printer's printing area and hence clip the image. It is advisable to use
printing preview or print the image to a PDF file before sending to a physical printer.

Heading
Include: Turn the header on and off.
Background Color: This is the color of the background in the header area.
Text Color: This is the color used for the text of the header.
Font: This is the font used for the header. Depending on the resize mode being used the font

size may be altered.
Left Text: This is the text placed in the left third of the header.
Center Text: This is the text placed in the center third of the header.
Right Text: This is the text placed in the right third of the header.

Styles
Background Color: This is the color of the background in the schedule item.
Text Color: This is the color used for the text of the schedule item.
Font: This is the font used for the schedule item. Depending on the resize mode being used

the font size may be altered.
Justification: This is the horizontal text justification for the text inside the schedule item box.

The options here are left, center, and right.
Alignment: This is the text vertical alignment for the text inside the schedule item box. The

options here are top, middle, and bottom.
Spacing: This turns on and off the spacing between the lines of text. If this is turned on the

lines will be equally spaced vertically inside the area, and if turned off the lines will be spaced at
the font height of the text.



File and Exporting Options

Once the schedule is created you can save the information to a file, copy or save the image,
and of course print or print preview the schedule card. These options are all in the main
menu and/or toolbar of the program.

Opening a Schedule File: If a schedule was saved to a file you can open the
information back up by selecting File > Open from the main menu or clicking the
corresponding tool in the toolbar (or Ctrl+O). At that point an open dialog box will appear
and allow you to select a file. Schedule files use a default extension of .pas (Personal
Academic Schedule). The program is also set up to load files at startup. So setting this
program as the default application for .pas files will allow the user to select the file from a
file explorer program on their respective operating system.

Saving a Schedule File: By selecting File > Save or File > Save As from the main
menu (or corresponding toolbar tool or Ctrl+S) a save dialog box will appear allowing the
selection or input of a filename. If there is a file already loaded then saving will overwrite
this file with the new contents.

Opening an Options File: You can also open saved options, without any schedule
items, by selecting File > Open Options from the main menu. This will load the saved
options (except header text) into the application. Extensions for these files are .pso
(Personal Schedule Options).

Saving an Options File: By selecting File > Save Options As from the main menu you
will get a save as dialog box to save the current options, except header text.

Printing the Schedule: Selecting File > Print or the corresponding toolbar tool or
Ctrl+P will bring up the print dialog box that will allow you to make some printing option
selections and finally send the image to the printer. The default orientation for printing is
landscape, this can be changed in the dialog options.

Print Preview of the Schedule: Selecting File > Print Preview or the corresponding
toolbar tool will bring up the print preview dialog box that will allow you to make some
printing option selections and finally send the image to the printer.

Saving the Schedule Image: Select File > Save Image As from the main menu or
corresponding toolbar tool and a save as dialog box will appear allowing the user to select
an image filename for the image. The default image format is PNG but other formats can
be written. The program selects the format based on the file extension used for the
filename. The supported formats are BMP, JPG, JPEG, PNG, PPM, XBM, and XPM.


